<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://www.ilovekent.net/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.ilovekent.net/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://www.ilovekent.net';var et_post_id='150987';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>

<title>Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent</title><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v28/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsjZ0B4gaVI.woff2" crossorigin><link rel="preload" as="font" href="https://www.ilovekent.net/wp-content/plugins/weather-atlas/public/font/weather-icons/weathericons-regular-webfont.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v28/memtYaGs126MiZpBA-UFUIcVXSCEkx2cmqvXlWqWuU6F.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v28/memvYaGs126MiZpBA-UvWbX2vVnXBbObj2OVTS-muw.woff2" crossorigin><link rel="preload" as="font" href="https://www.ilovekent.net/wp-content/themes/Extra-2/fonts/ET-Extra.woff" crossorigin><link rel="preload" as="font" href="https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.1.1" crossorigin><style id="wpr-usedcss">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</style>
<meta name="description" content="A Kent Station Pop-Up Blood Donor Center will have over 170 open appointments for the month of May, 2022, and donors are needed." />
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent" />
<meta property="og:description" content="A Kent Station Pop-Up Blood Donor Center will have over 170 open appointments for the month of May, 2022, and donors are needed." />
<meta property="og:url" content="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/" />
<meta property="og:site_name" content="iLoveKent" />
<meta property="article:tag" content="blood" />
<meta property="article:tag" content="Blood Donor Pop-up Center" />
<meta property="article:tag" content="blood drive" />
<meta property="article:tag" content="bloodworks northwest" />
<meta property="article:tag" content="health" />
<meta property="article:tag" content="Kent" />
<meta property="article:tag" content="Kent Station" />
<meta property="article:tag" content="news" />
<meta property="article:section" content="Events" />
<meta property="og:image" content="https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg" />
<meta property="og:image:secure_url" content="https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="640" />
<meta property="og:image:alt" content="Kent" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-04-26T10:36:42-07:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent" />
<meta name="twitter:description" content="A Kent Station Pop-Up Blood Donor Center will have over 170 open appointments for the month of May, 2022, and donors are needed." />
<meta name="twitter:image" content="https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Scott Schaefer" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NewsMediaOrganization","Organization"],"@id":"https://www.ilovekent.net/#organization","name":"South King Media","url":"https://www.ilovekent.net","logo":{"@type":"ImageObject","@id":"https://www.ilovekent.net/#logo","url":"https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png","caption":"South King Media","inLanguage":"en-US","width":"544","height":"180"}},{"@type":"WebSite","@id":"https://www.ilovekent.net/#website","url":"https://www.ilovekent.net","name":"South King Media","publisher":{"@id":"https://www.ilovekent.net/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg","url":"https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg","width":"1280","height":"640","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.ilovekent.net","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.ilovekent.net/category/things-to-do/events/","name":"Events"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/","name":"Blood Donors needed for Kent Station Pop-Up Donor Center in May"}}]},{"@type":"Person","@id":"https://www.ilovekent.net/author/scott-schaefer/","name":"Scott Schaefer","url":"https://www.ilovekent.net/author/scott-schaefer/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/4257112234b949a05d7bd0702f3feea5?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/4257112234b949a05d7bd0702f3feea5?s=96&amp;d=mm&amp;r=g","caption":"Scott Schaefer","inLanguage":"en-US"},"worksFor":{"@id":"https://www.ilovekent.net/#organization"}},{"@type":"WebPage","@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#webpage","url":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/","name":"Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent","datePublished":"2022-04-26T10:36:42-07:00","dateModified":"2022-04-26T10:36:42-07:00","author":{"@id":"https://www.ilovekent.net/author/scott-schaefer/"},"isPartOf":{"@id":"https://www.ilovekent.net/#website"},"primaryImageOfPage":{"@id":"https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#breadcrumb"}},{"@type":"NewsArticle","headline":"Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent","keywords":"Kent,Blood,blood donors,health,Kent Station","datePublished":"2022-04-26T10:36:42-07:00","dateModified":"2022-04-26T10:36:42-07:00","author":{"@id":"https://www.ilovekent.net/author/scott-schaefer/"},"publisher":{"@id":"https://www.ilovekent.net/#organization"},"description":"A Kent Station Pop-Up Blood Donor Center will have over 170 open appointments for the month of May, 2022, and donors are needed.","name":"Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent","@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#richSnippet","isPartOf":{"@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#webpage"},"image":{"@id":"https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; Feed" href="https://www.ilovekent.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; Comments Feed" href="https://www.ilovekent.net/comments/feed/" />
<link rel="alternate" type="text/calendar" title="iLoveKent &raquo; iCal Feed" href="https://www.ilovekent.net/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; Blood Donors needed for Kent Station Pop-Up Donor Center in May Comments Feed" href="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/feed/" />
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ilovekent.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="Extra v.2.27.4" name="generator" />
<link rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='preload' as='font' id='wpzoom-social-icons-font-academicons-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-academicons-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-woff2-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-socicon-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.4' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-socicon-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.4' type='font/woff' crossorigin />
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' data-cfasync='false' src='https://www.ilovekent.net/wp-content/cache/min/1/init-2.min.js?ver=1650587047' id='broadstreet-cdn-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js' defer></script>
<link rel="https://api.w.org/" href="https://www.ilovekent.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ilovekent.net/wp-json/wp/v2/posts/150987" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ilovekent.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ilovekent.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://www.ilovekent.net/?p=150987' />
<link rel="alternate" type="application/json+oembed" href="https://www.ilovekent.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ilovekent.net%2F2022%2F04%2F26%2Fblood-donors-needed-for-kent-station-pop-up-donor-center-in-may%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ilovekent.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ilovekent.net%2F2022%2F04%2F26%2Fblood-donors-needed-for-kent-station-pop-up-donor-center-in-may%2F&#038;format=xml" />
<meta property="fb:pages" content="141046720082" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.ilovekent.net"><link rel="alternate" href="https://www.ilovekent.net/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><script type="rocketlazyloadscript" id="google_gtagjs" src="https://www.googletagmanager.com/gtag/js?id=UA-6242924-4" async="async" data-rocket-type="text/javascript"></script>
<script type="rocketlazyloadscript" id="google_gtagjs-inline" data-rocket-type="text/javascript">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());gtag('config', 'UA-6242924-4', {} );
</script>
<script type="rocketlazyloadscript">
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=1G3A5rMjetngCmr1XJyGjwsm";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>
<script type="rocketlazyloadscript">
var year = new Date();
year = year.getFullYear();
jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://www.southkingmedia.com">South King Media</a> | Powered by South King Media');
});
</script>
<script type="rocketlazyloadscript">
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH I LOVE KENT...').css('opacity','1'); 
});
</script>
<meta property="fb:pages" content="141046720082"><link rel="icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-150987 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_non_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="">
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/ilovekent/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/ilovekentwa" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon rss">
<a href="https://www.ilovekent.net/feed" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-rss"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://www.ilovekent.net/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://www.ilovekent.net/" data-fixed-height="51">
<img width="544" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20544%20180'%3E%3C/svg%3E" alt="iLoveKent" id="logo" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png" /><noscript><img width="544" height="180" src="https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png" alt="iLoveKent" id="logo" /></noscript>
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-143065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143065"><a href="https://ilovekent.net">Home</a></li>
<li id="menu-item-146793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-146793"><a href="https://www.ilovekent.net/events/">Events</a></li>
<li id="menu-item-148103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-148103"><a href="https://www.ilovekent.net/crime/">Crime</a></li>
<li id="menu-item-144793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144793"><a href="https://www.ilovekent.net/category/COVID-19/">COVID-19</a></li>
<li id="menu-item-16938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16938"><a href="https://www.ilovekent.net/jobs/">Jobs</a></li>
<li id="menu-item-17034" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17034"><a href="https://www.ilovekent.net/category/ae/">A &#038; E</a></li>
<li id="menu-item-16852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16852"><a href="https://www.ilovekent.net/webcams/">Webcams</a></li>
<li id="menu-item-18804" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18804"><a href="https://www.ilovekent.net/videos/">Videos</a></li>
<li id="menu-item-16997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16997"><a href="https://www.ilovekent.net/advertising/">Advertise</a></li>
<li id="menu-item-16996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children mega-menu menu-item-has-children mega-menu-cols menu-item-16996"><a href="https://www.ilovekent.net/about-us/">About</a>
<ul class="sub-menu">
<li id="menu-item-17000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17000"><a href="https://www.ilovekent.net/about-us/">About</a></li>
<li id="menu-item-16999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16999"><a href="https://www.ilovekent.net/contact-us/">Contact</a></li>
<li id="menu-item-18772" class="menu-item menu-item-type-custom menu-item-object-custom mega-menu menu-item-has-children mega-menu-cols menu-item-18772"><a href="https://www.ilovekent.net/newsletter/">Newsletter</a></li>
<li id="menu-item-19506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19506"><a href="https://www.ilovekent.net/privacy-policy/">Terms/Privacy Policy</a></li>
<li id="menu-item-17187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17187"><a href="https://www.ilovekent.net/about-kent/">About Kent</a></li>
</ul>
</li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-150987" class="module single-post-module post-150987 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-featured category-health_wellness category-kent-news category-kent-wa-news category-news tag-blood tag-blood-donor-pop-up-center tag-blood-drive tag-bloodworks-northwest tag-health tag-kent tag-kent-station tag-news et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Blood Donors needed for Kent Station Pop-Up Donor Center in May</h1>
<div class="post-meta vcard">
<p><span class="updated">Apr 26, 2022</span> | <a href="https://www.ilovekent.net/category/things-to-do/events/" rel="tag">Events</a>, <a href="https://www.ilovekent.net/category/featured/" rel="tag">Featured</a>, <a href="https://www.ilovekent.net/category/health_wellness/" rel="tag">Health &amp; Wellness</a>, <a href="https://www.ilovekent.net/category/kent-news/" rel="tag">Kent News</a>, <a href="https://www.ilovekent.net/category/kent-wa-news/" rel="tag">Kent WA News</a>, <a href="https://www.ilovekent.net/category/news/" rel="tag">News</a> | <a class="comments-link" href="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img width="1280" height="640" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201280%20640'%3E%3C/svg%3E" alt="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22-1280x640.jpg" /><noscript><img width="1280" height="640" src="https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22-1280x640.jpg" alt="Blood Donors needed for Kent Station Pop-Up Donor Center in May" /></noscript> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>A Kent Station Pop-Up Blood Donor Center will have over 170 open appointments for the month of May, 2022, and donors are needed.</strong></p>
<p>Dates available include May 4, 6, 11, 12, 18, 20, 24 &amp; 25.</p>
<p>&#8220;Give blood to make your Mom proud.&#8221;</p>
<p>Sign up to saves lives by clicking the link below, or call 800-398-7888:</p>
<p style="text-align: center;"><a href="https://schedule.bloodworksnw.org/DonorPortal/GroupLanding.aspx?s=3005" target="_blank" rel="noopener"></p>
<p><strong><u>https://schedule.bloodworksnw.org/DonorPortal/GroupLanding.aspx?s=3005</strong></a></u></p>
<p>&#8220;Someone’s tomorrow needs a blood donor today!&#8221;</p>
<ul>
<li style="list-style-type: none;">
<ul>
<li>No walk-ins, guests, or people under age 16 are permitted onsite.</li>
<li>Donors are asked to bring a mask/face covering to your donation, and appointments are required.</li>
<li>Been told you’re ineligible? There are other significant ways to help! Even if you can’t give blood for patient care you CAN give blood for medical research—and we need you! Please consider participating in our research program or becoming a volunteer.</li>
<li>Please see <a href="http://bloodworksnw.org/coronavirus" target="_blank" rel="noopener"><strong>bloodworksnw.org/coronavirus</strong></a> for more information on steps we’re taking to keep our donors and staff safe.</li>
<li>There is no wait to donate if you receive the Pfizer, Moderna, Johnson &amp; Johnson/Janssen, Novovax or AstraZeneca COVID vaccine.</li>
<li>Donating blood is an essential and encouraged activity critical to sustaining community healthcare.</li>
<li>Your one-hour donation appointment is a safe action to support local hospitals and patients.</li>
<li>Pop-Up Donor Centers are being conducted in accordance with social distancing guidelines. APPIOINTMENT ONLY!</li>
</ul>
</li>
</ul>
<p>The Pop-up Blood Donor Center will be located at 438 Ramsay Way, across from Windermere Real Estate:</p>
<p><center><iframe src="about:blank" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy" referrerpolicy="no-referrer-when-downgrade" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2793.8561818857215!2d-122.23821184889432!3d47.38550691111594!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x54905bfee3f29ffd%3A0xf18cabee238f5ad7!2s438%20Ramsay%20Way%2C%20Kent%2C%20WA%2098032!5e1!3m2!1sen!2sus!4v1650994255765!5m2!1sen!2sus"></iframe><noscript><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2793.8561818857215!2d-122.23821184889432!3d47.38550691111594!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x54905bfee3f29ffd%3A0xf18cabee238f5ad7!2s438%20Ramsay%20Way%2C%20Kent%2C%20WA%2098032!5e1!3m2!1sen!2sus!4v1650994255765!5m2!1sen!2sus" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy" referrerpolicy="no-referrer-when-downgrade"></iframe></noscript></center></p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_906103012'><broadstreet-zone callback="zone_load_906103012" zone-id="76163" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script type="rocketlazyloadscript">window.zone_load_906103012 = function(z, d) { if (!d.count) document.getElementById('zone_load_906103012').style.display = 'none'; };</script> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/&#038;t=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Facebook" data-network-name="facebook" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May%20https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Twitter" data-network-name="twitter" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/&#038;t=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Google +" data-network-name="googleplus" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/&#038;description=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May&#038;media=https://www.ilovekent.net/wp-content/uploads/2022/04/ILK-KentStationBloodPopupMay22-225x128.jpg" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Pinterest" data-network-name="pinterest" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/&#038;title=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="http://www.stumbleupon.com/badge?url=https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/&#038;title=Blood%20Donors%20needed%20for%20Kent%20Station%20Pop-Up%20Donor%20Center%20in%20May" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Email" data-network-name="basic_email" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Blood Donors needed for Kent Station Pop-Up Donor Center in May&quot; via Print" data-network-name="basic_print" data-share-title="Blood Donors needed for Kent Station Pop-Up Donor Center in May" data-share-url="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://www.ilovekent.net/2022/04/22/discover-kent-business-expo-featuring-taste-of-kent-will-be-thursday-may-19/" rel="prev"><span class="button">Previous</span><span class="title">Discover Kent Business Expo featuring Taste of Kent will be Thursday, May 19</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
<center><div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span></h3><form action="https://www.ilovekent.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='150987' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="61e2ed7d90" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="58" /><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="gtranslate-2" class="et_pb_widget widget_gtranslate"><h4 class="widgettitle">Translate</h4>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2024%2024'%3E%3C/svg%3E" height="24" width="24" alt="en" data-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" /><noscript><img src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /></noscript> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/es.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script type="rocketlazyloadscript">
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<div id="google_translate_element2"></div>
<script type="rocketlazyloadscript">function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script type="rocketlazyloadscript">
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
</div> <div id="search-3" class="et_pb_widget widget_search"><h4 class="widgettitle">Search I Love Kent</h4><form role="search" method="get" class="search-form" action="https://www.ilovekent.net/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-7" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76175" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81628" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div class="tribe-compatibility-container">
<div class="tribe-common tribe-events tribe-events-view tribe-events-view--widget-events-list tribe-events-widget" data-js="tribe-events-view" data-view-rest-nonce="270763ce9b" data-view-rest-url="https://www.ilovekent.net/wp-json/tribe/views/v2/html" data-view-manage-url="1" data-view-breakpoint-pointer="c045aeb7-d350-4f8d-b782-a1b1e4e6eb8e">
<div class="tribe-events-widget-events-list">
<script type="application/ld+json">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</script>
<script data-js="tribe-events-view-data" type="application/json">
	{"slug":"widget-events-list","prev_url":"","next_url":"","view_class":"Tribe\\Events\\Views\\V2\\Views\\Widgets\\Widget_List_View","view_slug":"widget-events-list","view_label":"Widget-events-list","view":null,"should_manage_url":true,"id":null,"alias-slugs":null,"title":"Blood Donors needed for Kent Station Pop-Up Donor Center in May - iLoveKent","limit":"10","no_upcoming_events":true,"featured_events_only":false,"jsonld_enable":true,"tribe_is_list_widget":false,"admin_fields":{"title":{"label":"Title:","type":"text","classes":"","dependency":"","id":"widget-tribe-widget-events-list-3-title","name":"widget-tribe-widget-events-list[3][title]","options":[],"placeholder":"","value":null},"limit":{"label":"Show:","type":"number","default":5,"min":1,"max":10,"step":1,"classes":"","dependency":"","id":"widget-tribe-widget-events-list-3-limit","name":"widget-tribe-widget-events-list[3][limit]","options":[],"placeholder":"","value":null},"no_upcoming_events":{"label":"Hide this widget if there are no upcoming events.","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-3-no_upcoming_events","name":"widget-tribe-widget-events-list[3][no_upcoming_events]","options":[],"placeholder":"","value":null},"featured_events_only":{"label":"Limit to featured events only","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-3-featured_events_only","name":"widget-tribe-widget-events-list[3][featured_events_only]","options":[],"placeholder":"","value":null},"jsonld_enable":{"label":"Generate JSON-LD data","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-3-jsonld_enable","name":"widget-tribe-widget-events-list[3][jsonld_enable]","options":[],"placeholder":"","value":null}},"events":[150901,150946,150921,150905,150960,150897],"url":"https:\/\/www.ilovekent.net\/?post_type=tribe_events&eventDisplay=widget-events-list","url_event_date":false,"bar":{"keyword":"","date":""},"today":"2022-04-26 00:00:00","now":"2022-04-26 10:38:14","rest_url":"https:\/\/www.ilovekent.net\/wp-json\/tribe\/views\/v2\/html","rest_method":"POST","rest_nonce":"270763ce9b","today_url":"https:\/\/www.ilovekent.net\/?post_type=tribe_events&eventDisplay=widget-events-list&year=2022&monthnum=04&day=26&name=blood-donors-needed-for-kent-station-pop-up-donor-center-in-may","prev_label":"","next_label":"","date_formats":{"compact":"Y-m-d","month_and_year_compact":"Y-m","month_and_year":"F Y","time_range_separator":" - ","date_time_separator":" @ "},"messages":[],"start_of_week":"0","breadcrumbs":[],"before_events":"","after_events":"\n<!--\nThis calendar is powered by The Events Calendar.\nhttp:\/\/evnt.is\/18wn\n-->\n","display_events_bar":false,"disable_event_search":false,"live_refresh":true,"ical":{"display_link":true,"link":{"url":"https:\/\/www.ilovekent.net\/?post_type=tribe_events&#038;eventDisplay=widget-events-list&#038;ical=1","text":"Export Events","title":"Use this to share calendar data with Google Calendar, Apple iCal and other compatible apps"}},"container_classes":["tribe-common","tribe-events","tribe-events-view","tribe-events-view--widget-events-list","tribe-events-widget"],"container_data":[],"is_past":false,"breakpoints":{"xsmall":500,"medium":768,"full":960},"breakpoint_pointer":"c045aeb7-d350-4f8d-b782-a1b1e4e6eb8e","is_initial_load":true,"public_views":{"month":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Month_View","view_url":"https:\/\/www.ilovekent.net\/events\/month\/","view_label":"Month"},"day":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Day_View","view_url":"https:\/\/www.ilovekent.net\/events\/today\/","view_label":"Day"}},"show_latest_past":false,"compatibility_classes":["tribe-compatibility-container"],"view_more_text":"View Calendar","view_more_title":"View more events.","view_more_link":"https:\/\/www.ilovekent.net\/events\/","widget_title":"Upcoming Events","hide_if_no_upcoming_events":true,"display":[],"subscribe_links":{"gcal":{"label":"Google Calendar","single_label":"Add to Google Calendar","visible":true},"ical":{"label":"iCalendar","single_label":"Add to iCalendar","visible":true}},"_context":{"slug":"widget-events-list"}}</script>
<header class="tribe-events-widget-events-list__header">
<h2 class="tribe-events-widget-events-list__header-title tribe-common-h6 tribe-common-h--alt">
Upcoming Events </h2>
</header>
<div class="tribe-events-widget-events-list__events">
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-04-27">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Apr </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
27 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150901 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-04-27">
<span class="tribe-event-date-start">April 27 @ 8:00 pm</span> - <span class="tribe-event-date-end">April 30 @ 9:30 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/catch-kentridge-high-schools-high-flying-musical-catch-me-if-you-can-april-27-may-7/" title="Catch Kentridge High School&#8217;s high-flying musical &#8216;Catch Me If You Can&#8217; April 27-May 7" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Catch Kentridge High School&#8217;s high-flying musical &#8216;Catch Me If You Can&#8217; April 27-May 7	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-03">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
3 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150946 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-03">
<span class="tribe-event-date-start">5:30 pm</span> - <span class="tribe-event-time">7:30 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/kent-downtown-partnership-volunteer-open-house-mixer-is-tuesday-may-3/" title="Kent Downtown Partnership Volunteer Open House &#038; Mixer is Tuesday, May 3" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Kent Downtown Partnership Volunteer Open House &#038; Mixer is Tuesday, May 3	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-04">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
4 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150921 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-04">
<span class="tribe-event-date-start">4:00 pm</span> - <span class="tribe-event-time">6:00 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/multi-service-center-holding-open-house-ribbon-cutting-at-new-kent-office-wed-may-4/" title="Multi-Service Center holding Open House &#038; Ribbon Cutting at new Kent office Wed., May 4" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Multi-Service Center holding Open House &#038; Ribbon Cutting at new Kent office Wed., May 4	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-04">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
4 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150905 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-04">
<span class="tribe-event-date-start">May 4 @ 8:00 pm</span> - <span class="tribe-event-date-end">May 7 @ 9:30 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/catch-kentridge-high-schools-high-flying-musical-catch-me-if-you-can-april-27-may-7-2/" title="Catch Kentridge High School&#8217;s high-flying musical &#8216;Catch Me If You Can&#8217; April 27-May 7" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Catch Kentridge High School&#8217;s high-flying musical &#8216;Catch Me If You Can&#8217; April 27-May 7	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-06-04">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jun </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
4 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150960 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-06-04">
<span class="tribe-event-date-start">5:30 pm</span> - <span class="tribe-event-time">9:00 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/multi-service-centers-crab-feed-and-auction-will-be-saturday-june-4/" title="Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-06-10">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jun </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
10 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-150897 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-06-10">
<span class="tribe-event-date-start">6:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> <span class='timezone'> PDT </span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://www.ilovekent.net/event/save-the-date-downtown-kent-wine-walk-will-be-friday-june-10/" title="Downtown Kent Wine Walk will be Friday, June 10" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Downtown Kent Wine Walk will be Friday, June 10	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
</div>
<div class="tribe-events-widget-events-list__view-more tribe-common-b1 tribe-common-b2--min-medium">
<a href="https://www.ilovekent.net/events/" class="tribe-events-widget-events-list__view-more-link tribe-common-anchor-thin" title="View more events.">
View Calendar	</a>
</div>
</div>
</div>
</div>
<script type="rocketlazyloadscript" class="tribe-events-breakpoints">
	( function () {
		var completed = false;

		function initBreakpoints() {
			if ( completed ) {
				// This was fired already and completed no need to attach to the event listener.
				document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
				return;
			}

			if ( 'undefined' === typeof window.tribe ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views.breakpoints ) {
				return;
			}

			if ( 'function' !== typeof (window.tribe.events.views.breakpoints.setup) ) {
				return;
			}

			var container = document.querySelectorAll( '[data-view-breakpoint-pointer="c045aeb7-d350-4f8d-b782-a1b1e4e6eb8e"]' );
			if ( ! container ) {
				return;
			}

			window.tribe.events.views.breakpoints.setup( container );
			completed = true;
			// This was fired already and completed no need to attach to the event listener.
			document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
		}

		// Try to init the breakpoints right away.
		initBreakpoints();
		document.addEventListener( 'DOMContentLoaded', initBreakpoints );
	})();
</script>
<div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76176" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76177" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#3366cc;border:1px solid #2255bb;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #2255bb'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Kent</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script type="rocketlazyloadscript">/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-11'></i><span class='temp'>48°</span><div class='current_text'>Rain Shower</div><div class='sunrise_sunset'>5:59am<i class='wi wi-fw wi-weather-32'></i>8:13pm PDT</div></div><span class='current_text_2'>Feels like: 45<small>°F</small><br />Wind: 10<small>mph</small> SSW<br />Humidity: 73<small>%</small><br />Pressure: 30.05<small>"Hg</small><br />UV index: 2</span><div class='daily days' style='border-bottom:1px solid #2255bb'><span class='extended_day extended_day_1'>Wed</span><span class='extended_day extended_day_2'>Thu</span><span class='extended_day extended_day_3'>Fri</span></div><div class='daily'><span class='extended_day extended_day_1' title='Partly Cloudy'>57/39<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_2' title='PM Showers'>55/43<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_3' title='Mostly Cloudy'>61/48<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #2255bb'><a href='https://www.weather-atlas.com/en/washington-usa/kent' title='Weather Atlas - Weather forecast Kent, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Kent, Washington &#9656;</span></a></div></div></div> <div id="text-19" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://www.ilovekent.net/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20150'%3E%3C/svg%3E" alt="" width="300" height="150" data-lazy-src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" /><noscript><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></noscript></a></p>
</div>
</div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76178" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-16" class="et_pb_widget widget_text"><h4 class="widgettitle">Subscribe to our Newsletter</h4> <div class="textwidget"><p>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fb8b0aece" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE 6pm Daily Digest Newsletter!</label><br />
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><br />
</p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fb8b0aece" tabindex="-1" value=""></div>
<div class="black"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div>
<p></p>
</div>
</div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--round zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.facebook.com/ilovekent/" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/ilovekentwa" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.instagram.com/ilovekentwa/" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#e4405f" style="background-color : #e4405f; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCPJBGxrGH_jWDXwprWUJHOQ" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
</ul>
</div> <div id="text-13" class="et_pb_widget widget_text"><h4 class="widgettitle">Story Idea or News Tip?</h4> <div class="textwidget"><p><center><strong>Send story ideas &amp; tips to us at:</strong></p>
<p><strong>editor(at)ilovekent.net</strong></p>
<p>You can also text us or leave a voicemail 24/7:</p>
<p><strong>(206) 659-1282</strong></p>
<p>Or call our office at <strong>(206) 248-2565</strong>!</center></p>
</div>
</div> <div id="bs_zones-17" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76166" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-25" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76167" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-14" class="et_pb_widget widget_text"><h4 class="widgettitle">Traffic Cams</h4> <div class="textwidget"><p><img loading="lazy" class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20249'%3E%3C/svg%3E" width="335" height="249" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc01964.jpg?636501523088772706" /><noscript><img loading="lazy" class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc01964.jpg?636501523088772706" width="335" height="249" /></noscript></p>
<p><img loading="lazy" class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20249'%3E%3C/svg%3E" width="335" height="249" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc02189.jpg?636501523589242393" /><noscript><img loading="lazy" class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc02189.jpg?636501523589242393" width="335" height="249" /></noscript></p>
<p><img loading="lazy" class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20244'%3E%3C/svg%3E" width="335" height="244" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc02459.jpg?636753046944636747" /><noscript><img loading="lazy" class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc02459.jpg?636753046944636747" width="335" height="244" /></noscript></p>
</div>
</div> 
<div id="recent-posts-3" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://www.ilovekent.net/2022/04/26/blood-donors-needed-for-kent-station-pop-up-donor-center-in-may/" aria-current="page">Blood Donors needed for Kent Station Pop-Up Donor Center in May</a>
</li>
<li>
<a href="https://www.ilovekent.net/2022/04/22/discover-kent-business-expo-featuring-taste-of-kent-will-be-thursday-may-19/">Discover Kent Business Expo featuring Taste of Kent will be Thursday, May 19</a>
</li>
<li>
<a href="https://www.ilovekent.net/2022/04/21/kent-lions-club-bringing-back-kent-cornucopia-days-this-summer/">Kent Lions Club bringing back Kent Cornucopia Days this summer</a>
</li>
<li>
<a href="https://www.ilovekent.net/2022/04/21/multi-service-centers-crab-feed-and-auction-will-be-saturday-june-4/">Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4</a>
</li>
<li>
<a href="https://www.ilovekent.net/2022/04/20/israel-vela-selected-as-superintendent-for-kent-school-district/">Israel Vela selected as new Superintendent for Kent School District</a>
</li>
</ul>
</div> <div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">daniel</span> on <a href="https://www.ilovekent.net/2022/04/20/tiny-home-village-awakens-27-public-comments-during-kent-city-council-tuesday-night/#comment-14848">Tiny home village awakens 27 public comments during Kent City Council Tuesday night</a></li><li class="recentcomments"><span class="comment-author-link">Scott Schaefer</span> on <a href="https://www.ilovekent.net/2022/04/07/shukri-olow-announces-candidacy-for-state-rep-for-47th-district/#comment-14837">Shukri Olow announces candidacy for State Rep. for 47th District</a></li><li class="recentcomments"><span class="comment-author-link">DB</span> on <a href="https://www.ilovekent.net/2022/04/07/shukri-olow-announces-candidacy-for-state-rep-for-47th-district/#comment-14835">Shukri Olow announces candidacy for State Rep. for 47th District</a></li><li class="recentcomments"><span class="comment-author-link"><a href="http://Website%20%20I%20love%20kent" rel="external nofollow ugc" class="url">Name *sylvia Hildebrandt</a></span> on <a href="https://www.ilovekent.net/2022/03/21/amazon-cited-for-unsafe-work-practices-at-kent-fulfillment-center/#comment-14824">Amazon cited for unsafe work practices at Kent fulfillment center</a></li><li class="recentcomments"><span class="comment-author-link">R</span> on <a href="https://www.ilovekent.net/2022/03/16/washington-state-patrol-seeking-witnesses-to-felony-hit-and-run-on-sr-167-in-kent/#comment-14822">Washington State Patrol seeking witnesses to felony hit-and-run on SR 167 in Kent</a></li></ul></div> <div id="bs_zones-13" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76172" keywords="not_home_page,not_landing_page,is_article_page,events,things-to-do,featured,health_wellness,kent-news,kent-wa-news,news,blood-donors-needed-for-kent-station-pop-up-donor-center-in-may,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul id="footer-menu" class="bottom-nav"><li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55"><a href="http://ilovekent.net/new/disclaimer">Disclaimer</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56"><a href="#">Privacy</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57"><a href="https://www.ilovekent.net/new/advertising/">Advertisement</a></li>
<li id="menu-item-58" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58"><a href="https://www.ilovekent.net/new/contact/">Contact Us</a></li>
</ul> <ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/ilovekent/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/ilovekentwa" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon rss">
<a href="https://www.ilovekent.net/feed" class="et-extra-icon et-extra-icon-background-none et-extra-icon-rss"></a>
</li>
 </ul>
</div> 
</div>
</div>
</footer>
</div> 
<script type="rocketlazyloadscript" data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','events','things-to-do','featured','health_wellness','kent-news','kent-wa-news','news','blood-donors-needed-for-kent-station-pop-up-donor-center-in-may','post']</script>
<script type="rocketlazyloadscript" data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["events","things-to-do","featured","health_wellness","kent-news","kent-wa-news","news","blood-donors-needed-for-kent-station-pop-up-donor-center-in-may","post"],"url":"blood-donors-needed-for-kent-station-pop-up-donor-center-in-may"};</script>
<script type="rocketlazyloadscript" data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script><div style="position:fixed;bottom:0px;right:8%;z-index:999999;" id="gtranslate_wrapper">
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2024%2024'%3E%3C/svg%3E" height="24" width="24" alt="en" data-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" /><noscript><img src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /></noscript> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/es.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//www.ilovekent.net/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script type="rocketlazyloadscript">
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<div id="google_translate_element2"></div>
<script type="rocketlazyloadscript">function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script type="rocketlazyloadscript">
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
</div><script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/yottie-lite/assets/yottie-lite/dist/jquery.yottie-lite.bundled.js?ver=1650587045' id='yottie-lite-js' defer></script>
<script type="rocketlazyloadscript">
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
			</script>
<script type="rocketlazyloadscript"> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='pushengage-core-debug-js-before'>
// pe api/site key not found
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://clientcdn.pushengage.com?ver=5.9.3' id='pushengage-core-debug-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/ui/menu.min.js?ver=1.13.1' id='jquery-ui-menu-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/dom-ready.min.js?ver=ecda74de0221e1c2ce5c57cbb5af09d5' id='wp-dom-ready-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js'></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/a11y.min.js?ver=68e470cf840f69530e9db3be229ad4b6' id='wp-a11y-js' defer></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.13.1' id='jquery-ui-autocomplete-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js' defer></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/www.ilovekent.net\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"55370f3c02","timeline_nonce":"939d7b48c9","blog_feed_nonce":"80e6ab735c","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.ilovekent.net\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"92f6128970","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"aea293deff","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"150987","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/themes/Extra-2/scripts/scripts.min.js?ver=2.27.4' id='extra-scripts-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1650587045' id='zoom-social-icons-widget-frontend-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/themes/Extra-2/core/admin/js/common.js?ver=1650587045' id='et-core-common-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=4.14.16' id='tribe-common-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/the-events-calendar/common/src/resources/js/utils/query-string.js?ver=1650587045' id='tribe-query-string-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js?ver=1650587045' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js?ver=1650587045' defer></script>
<script type="rocketlazyloadscript" data-minify="1" defer data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/the-events-calendar/src/resources/js/views/manager.js?ver=1650587045' id='tribe-events-views-v2-manager-js'></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.ilovekent.net/wp-content/cache/min/1/wp-content/plugins/the-events-calendar/src/resources/js/views/breakpoints.js?ver=1650587045' id='tribe-events-views-v2-breakpoints-js' defer></script>
<script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script type="rocketlazyloadscript" data-no-minify="1" async src="https://www.ilovekent.net/wp-content/plugins/rocket-lazy-load/assets/js/16.1/lazyload.min.js"></script></body>
</html>
