<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://www.ilovekent.net/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.ilovekent.net/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script>var et_site_url='https://www.ilovekent.net';var et_post_id='147973';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>

<title>REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%7COpen%20Sans%3A300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C400%2C300%2C600%2C700%2C800&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://www.ilovekent.net/wp-content/cache/min/1/f485c0b67076971a272f70aa3449fc7a.css" media="all" data-minify="1" />
<meta name="description" content="REMINDER: The Kent Chamber of Commerce will be hosting Puget Sound Energy at its May membership luncheon this Thursday, May 6, 2021." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent">
<meta property="og:description" content="REMINDER: The Kent Chamber of Commerce will be hosting Puget Sound Energy at its May membership luncheon this Thursday, May 6, 2021.">
<meta property="og:url" content="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<meta property="og:site_name" content="iLoveKent">
<meta property="article:tag" content="business">
<meta property="article:tag" content="chamber">
<meta property="article:tag" content="Kent">
<meta property="article:tag" content="kent chamber of commerce">
<meta property="article:tag" content="membership luncheon">
<meta property="article:tag" content="news">
<meta property="article:tag" content="puget sound energy">
<meta property="article:section" content="Biz/Finance">
<meta property="og:updated_time" content="2021-05-05T15:03:51-07:00">
<meta property="og:image" content="https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg">
<meta property="og:image:secure_url" content="https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg">
<meta property="og:image:width" content="1280">
<meta property="og:image:height" content="640">
<meta property="og:image:alt" content="Kent Chamber">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent">
<meta name="twitter:description" content="REMINDER: The Kent Chamber of Commerce will be hosting Puget Sound Energy at its May membership luncheon this Thursday, May 6, 2021.">
<meta name="twitter:image" content="https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg">
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NewsMediaOrganization","Organization"],"@id":"https://www.ilovekent.net/#organization","name":"South King Media","url":"https://www.ilovekent.net","logo":{"@type":"ImageObject","@id":"https://www.ilovekent.net/#logo","url":"https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png","caption":"South King Media","inLanguage":"en-US","width":"544","height":"180"}},{"@type":"WebSite","@id":"https://www.ilovekent.net/#website","url":"https://www.ilovekent.net","name":"South King Media","publisher":{"@id":"https://www.ilovekent.net/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg","url":"https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg","width":"1280","height":"640","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.ilovekent.net/author/scott-schaefer/","name":"Scott Schaefer","url":"https://www.ilovekent.net/author/scott-schaefer/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/4257112234b949a05d7bd0702f3feea5?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/4257112234b949a05d7bd0702f3feea5?s=96&amp;d=mm&amp;r=g","caption":"Scott Schaefer","inLanguage":"en-US"},"worksFor":{"@id":"https://www.ilovekent.net/#organization"}},{"@type":"WebPage","@id":"https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/#webpage","url":"https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/","name":"REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent","datePublished":"2021-05-05T15:02:59-07:00","dateModified":"2021-05-05T15:03:51-07:00","author":{"@id":"https://www.ilovekent.net/author/scott-schaefer/"},"isPartOf":{"@id":"https://www.ilovekent.net/#website"},"primaryImageOfPage":{"@id":"https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent","keywords":"Kent Chamber,Kent,chamber,Puget Sound Energy,luncheon","datePublished":"2021-05-05T15:02:59-07:00","dateModified":"2021-05-05T15:03:51-07:00","author":{"@type":"Person","name":"Scott Schaefer"},"publisher":{"@id":"https://www.ilovekent.net/#organization"},"description":"REMINDER: The Kent Chamber of Commerce will be hosting Puget Sound Energy at its May membership luncheon this Thursday, May 6, 2021.","name":"REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday - iLoveKent","@id":"https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/#richSnippet","isPartOf":{"@id":"https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/#webpage"},"image":{"@id":"https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//ad.broadstreetads.com' />
<link rel='dns-prefetch' href='//cdn-images.mailchimp.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//google.com' />
<link rel='dns-prefetch' href='//googletagmanager.com' />
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//red.broadstreetads.com' />
<link rel='dns-prefetch' href='//scontent.xx.fbcdn.net' />
<link rel='dns-prefetch' href='//2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; Feed" href="https://www.ilovekent.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; Comments Feed" href="https://www.ilovekent.net/comments/feed/" />
<link rel="alternate" type="text/calendar" title="iLoveKent &raquo; iCal Feed" href="https://www.ilovekent.net/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="iLoveKent &raquo; REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday Comments Feed" href="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/feed/" />

<script data-rocketlazyloadscript='https://www.ilovekent.net/wp-content/cache/busting/1/gtm-92746ff6f1963807fca02adb095c9236.js' data-no-minify="1" type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-6242924-4';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-6242924-4', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>

<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="preload" as="font" id='wpzoom-social-icons-font-academicons-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-academicons-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-woff2-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='text/css' type="font/woff2" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-socicon-ttf-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.1.1' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-socicon-woff-css' href='https://www.ilovekent.net/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.1.1' type='text/css' type="font/woff" crossorigin />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.ilovekent.net/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.ilovekent.net\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":147973,"token":"f57eb3f6aa","lang":0,"debug":0}
</script>
<link rel="https://api.w.org/" href="https://www.ilovekent.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ilovekent.net/wp-json/wp/v2/posts/147973" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ilovekent.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ilovekent.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://www.ilovekent.net/?p=147973' />
<meta property="fb:pages" content="141046720082" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.ilovekent.net"><link rel="https://theeventscalendar.com/" href="https://www.ilovekent.net/wp-json/tribe/events/v1/" /> <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="amphtml" href="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/amp/"><script data-rocketlazyloadscript='https://www.googletagmanager.com/gtag/js?id=UA-6242924-4' id="google_gtagjs" async="async" type="text/javascript"></script>
<script data-rocketlazyloadscript='data:text/javascript;base64,CndpbmRvdy5kYXRhTGF5ZXIgPSB3aW5kb3cuZGF0YUxheWVyIHx8IFtdO2Z1bmN0aW9uIGd0YWcoKXtkYXRhTGF5ZXIucHVzaChhcmd1bWVudHMpO31ndGFnKCdzZXQnLCAnbGlua2VyJywgeyJkb21haW5zIjpbInd3dy5pbG92ZWtlbnQubmV0Il19ICk7Z3RhZygnanMnLCBuZXcgRGF0ZSgpKTtndGFnKCdjb25maWcnLCAnVUEtNjI0MjkyNC00Jywge30gKTsK' id="google_gtagjs-inline" type="text/javascript"></script>
<div id="pp-banner"></div>
<style>
.et-search-field { opacity: 0; }
</style><meta property="fb:pages" content="141046720082"><link rel="icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ilovekent.net/wp-content/uploads/2018/01/cropped-ILK512x512Trans-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-147973 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
  var OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
      appId: "75a2159c-7f17-47ea-be7c-38b6cc195335",
    });
  });
</script>
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-144291" class="et-trending-post et-trending-latest">
<a href="https://www.ilovekent.net/2020/03/04/city-of-kent-not-notified-of-countys-intent-to-turn-econo-lodge-into-coronavirus-quarantine/">City of Kent not notified of county&#8217;s intent to t...</a>
</div>
<div id="et-trending-post-12138" class="et-trending-post">
<a href="https://www.ilovekent.net/2016/10/12/voter-resources/">Voter Resources for Nov. 8 General Election</a>
</div>
<div id="et-trending-post-12292" class="et-trending-post">
<a href="https://www.ilovekent.net/2016/10/29/community-profile-nancy-simpson/">Community Profile: Nancy Simpson</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/ilovekent/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/ilovekentwa" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon rss">
<a href="https://www.ilovekent.net/feed" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-rss"></a>
</li>
</ul>

<div class="et-top-search" style="">
 <form role="search" class="et-search-form" method="get" action="https://www.ilovekent.net/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://www.ilovekent.net/" data-fixed-height="51">
<img width="544" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20544%20180'%3E%3C/svg%3E" alt="iLoveKent" id="logo" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png" /><noscript><img width="544" height="180" src="https://www.ilovekent.net/wp-content/uploads/2017/12/ILKLogo544x180-wht-1.png" alt="iLoveKent" id="logo" /></noscript>
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-143065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143065"><a href="https://ilovekent.net">Home</a></li>
<li id="menu-item-144793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144793"><a href="https://www.ilovekent.net/category/COVID-19/">COVID-19</a></li>
<li id="menu-item-146793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-146793"><a href="https://www.ilovekent.net/events/">Events</a></li>
<li id="menu-item-16851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16851"><a href="https://www.ilovekent.net/category/crime/">Crime</a></li>
<li id="menu-item-16938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16938"><a href="https://www.ilovekent.net/jobs/">Jobs</a></li>
<li id="menu-item-17034" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17034"><a href="https://www.ilovekent.net/category/ae/">A &#038; E</a></li>
<li id="menu-item-16852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16852"><a href="https://www.ilovekent.net/webcams/">Webcams</a></li>
<li id="menu-item-18804" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18804"><a href="https://www.ilovekent.net/videos/">Videos</a></li>
<li id="menu-item-16997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16997"><a href="https://www.ilovekent.net/advertising/">Advertise</a></li>
<li id="menu-item-16996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children mega-menu menu-item-has-children mega-menu-cols menu-item-16996"><a href="https://www.ilovekent.net/about-us/">About</a>
<ul class="sub-menu">
<li id="menu-item-17000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17000"><a href="https://www.ilovekent.net/about-us/">About</a></li>
<li id="menu-item-16999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16999"><a href="https://www.ilovekent.net/contact-us/">Contact</a></li>
<li id="menu-item-18772" class="menu-item menu-item-type-custom menu-item-object-custom mega-menu menu-item-has-children mega-menu-cols menu-item-18772"><a href="https://www.ilovekent.net/newsletter/">Newsletter</a></li>
<li id="menu-item-19506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19506"><a href="https://www.ilovekent.net/privacy-policy/">Terms/Privacy Policy</a></li>
<li id="menu-item-17187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17187"><a href="https://www.ilovekent.net/about-kent/">About Kent</a></li>
</ul>
</li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-147973" class="module single-post-module post-147973 post type-post status-publish format-standard has-post-thumbnail hentry category-biz-finance category-community category-featured category-kent-news category-kent-wa-news category-news category-nonprofit tag-business tag-chamber tag-kent tag-kent-chamber-of-commerce tag-membership-luncheon tag-news tag-puget-sound-energy et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday</h1>
<div class="post-meta vcard">
<p><span class="updated">May 5, 2021</span> | <a href="https://www.ilovekent.net/category/biz-finance/" rel="tag">Biz/Finance</a>, <a href="https://www.ilovekent.net/category/community/" rel="tag">Community</a>, <a href="https://www.ilovekent.net/category/featured/" rel="tag">Featured</a>, <a href="https://www.ilovekent.net/category/kent-news/" rel="tag">Kent News</a>, <a href="https://www.ilovekent.net/category/kent-wa-news/" rel="tag">Kent WA News</a>, <a href="https://www.ilovekent.net/category/news/" rel="tag">News</a>, <a href="https://www.ilovekent.net/category/nonprofit/" rel="tag">Nonprofit</a> | <a class="comments-link" href="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img width="1280" height="640" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201280%20640'%3E%3C/svg%3E" alt="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon-1280x640.jpg" /><noscript><img width="1280" height="640" src="https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon-1280x640.jpg" alt="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" /></noscript> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong><u>REMINDER</u>: The Kent Chamber of Commerce will be hosting Puget Sound Energy at its May membership luncheon this Thursday, May 6, 2021.</strong></p>
<p>This online event will run from 11:30 a.m. to 1 p.m.</p>
<p>The guest speaker will be Julien Loh.</p>
<p>PSE has a rich history of energy leadership, ground-breaking innovation and dedicated service to our customers and local communities.</p>
<p>&#8220;Our mission today is deep decarbonization and greenhouse gas emissions reduction. We will be coal free by 2025, carbon neutral by 2030, and have 100% clean electricity by 2045. Our local distribution system will have net zero methane emissions by 2022.&#8221;</p>
<h3 style="text-align: center;"><strong><u><a href="http://info.kentchamber.com/events/details/kcc-membership-luncheon-pse-248129" target="_blank" rel="noopener"><u>REGISTER ONLINE HERE</u></a></u></strong></h3>
<p style="text-align: left;">Once you register you will be provided with the zoom meeting link.</p>
<ul>
<li style="list-style-type: none;">
<ul>
<li style="text-align: left;">Event Sponsor: <em><a href="https://www.abyssiniabeautyclinic.com/" target="_blank" rel="noopener"><strong>Abyssinia Hair &amp; Beauty Clinic</strong></a></em></li>
<li style="text-align: left;">Media Sponsor: <em><strong><a href="https://www.ilovekent.net/">iLoveKent.net </a></strong></em></li>
</ul>
</li>
</ul>
<script data-rocketlazyloadscript='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js' async></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2062216921302425",
          enable_page_level_ads: true
     });
</script>
<br />
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fb8b0aece" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get FREE hyperlocal news for Kent daily via email – sign up here:</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fb8b0aece" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<br /><div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_633822603'><broadstreet-zone callback="zone_load_633822603" zone-id="76163" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/&#038;t=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Facebook" data-network-name="facebook" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday%20https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Twitter" data-network-name="twitter" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/&#038;t=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Google +" data-network-name="googleplus" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/&#038;description=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday&#038;media=https://www.ilovekent.net/wp-content/uploads/2021/05/ILK-KentChamberMay21Luncheon-225x128.jpg" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Pinterest" data-network-name="pinterest" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/&#038;title=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via LinkedIn" data-network-name="linkedin" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="http://www.stumbleupon.com/badge?url=https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/&#038;title=REMINDER%3A%20Kent%20Chamber%20Luncheon%20will%20feature%20Puget%20Sound%20Energy%20Thursday" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Email" data-network-name="basic_email" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday&quot; via Print" data-network-name="basic_print" data-share-title="REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday" data-share-url="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #3366cc;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://www.ilovekent.net/2021/05/05/you-can-now-bid/" rel="prev"><span class="button">Previous</span><span class="title">You can now bid to fly into space on Blue Origin&#8217;s New Shepard</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
<center><div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/05/05/reminder-kent-chamber-luncheon/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.ilovekent.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='147973' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="54217ede4f" /></p><input type="hidden" id="ak_js" name="ak_js" value="84" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-3" class="et_pb_widget widget_search"><h4 class="widgettitle">Search I Love Kent</h4><form role="search" method="get" class="search-form" action="https://www.ilovekent.net/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-7" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76175" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81628" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76176" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="tribe-events-list-widget-3" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-147976 tribe-clearfix tribe-events-venue-147223">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/kent-chamber-luncheon-will-feature-puget-sound-energy-thursday/" rel="bookmark">Kent Chamber Luncheon will feature Puget Sound Energy Thursday</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">May 6 @ 11:30 am</span> - <span class="tribe-event-time">1:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147825 tribe-clearfix tribe-events-venue-146955 tribe-events-organizer-146956">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/volunteers-needed-to-help-teamup-2-cleanup-in-downtown-kent-on-saturday-may-8/" rel="bookmark">Volunteers needed to help &#8216;Teamup 2 Cleanup&#8217; in downtown Kent on Saturday, May 8</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">May 8 @ 9:00 am</span> - <span class="tribe-event-time">1:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147829 tribe-clearfix tribe-events-venue-147223 tribe-events-organizer-147523">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/kent-city-council-meeting-10/" rel="bookmark">Kent City Council meeting</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">May 18 @ 7:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147914 tribe-clearfix tribe-events-venue-147223 tribe-events-organizer-147916">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/kent-school-district-holding-career-fair-on-saturday-may-22/" rel="bookmark">Kent School District holding Career Fair on Saturday, May 22</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">May 22 @ 10:00 am</span> - <span class="tribe-event-time">12:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147831 tribe-clearfix tribe-events-venue-147223 tribe-events-organizer-147523">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/kent-city-council-meeting-11/" rel="bookmark">Kent City Council meeting</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">June 1 @ 7:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147889 tribe-clearfix tribe-events-venue-147891 tribe-events-organizer-146956">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/help-the-kdp-by-walking-around-downtown-kent-between-june-3-17/" rel="bookmark">Help the KDP by walking around downtown Kent between June 3-17</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">June 3</span> - <span class="tribe-event-date-end">June 17</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-147833 tribe-clearfix tribe-events-venue-147223 tribe-events-organizer-147523">

<h4 class="tribe-event-title">
<a href="https://www.ilovekent.net/event/kent-city-council-meeting-12/" rel="bookmark">Kent City Council meeting</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">June 15 @ 7:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> <span class='timezone'> PDT </span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="https://www.ilovekent.net/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">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</script><div id="text-20" class="et_pb_widget widget_text"><h4 class="widgettitle">CANDIDATES GUIDE 2021</h4> <div class="textwidget"><p><a href="https://www.ilovekent.net/2021/03/08/think-youd-be-a-better-elected-official-heres-how-you-can-run-for-office/"><img class="aligncenter size-full wp-image-145675" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20100'%3E%3C/svg%3E" alt="" width="300" height="100" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2021/03/BTB-CandidatesGuide2021-b.jpg" /><noscript><img class="aligncenter size-full wp-image-145675" src="https://www.ilovekent.net/wp-content/uploads/2021/03/BTB-CandidatesGuide2021-b.jpg" alt="" width="300" height="100" /></noscript></a></p>
</div>
</div> <div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76177" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-17" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL RESTAURANTS</h4> <div class="textwidget"><p><a href="https://www.ilovekent.net/2020/03/23/support-local-restaurants-during-the-quarantine-heres-how-where-to-order-food/"><img class="aligncenter size-full wp-image-144581" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20150'%3E%3C/svg%3E" alt="" width="300" height="150" data-lazy-src="https://www.ilovekent.net/wp-content/uploads/2020/03/ILK-SupportLocalRestaurantsTakeOut20.jpg" /><noscript><img class="aligncenter size-full wp-image-144581" src="https://www.ilovekent.net/wp-content/uploads/2020/03/ILK-SupportLocalRestaurantsTakeOut20.jpg" alt="" width="300" height="150" /></noscript></a></p>
</div>
</div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#3366cc;border:1px solid #2255bb;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #2255bb'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Kent</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-32'></i><span class='temp'>72°</span><div class='current_text'>Sunny</div><div class='sunrise_sunset'>5:43am<i class='wi wi-fw wi-weather-32'></i>8:27pm PDT</div></div><span class='current_text_2'>Feels like: 72<small>°F</small><br />Wind: 8<small>mph</small> NNE<br />Humidity: 43<small>%</small><br />Pressure: 29.85<small>"Hg</small><br />UV index: 0</span><div class='daily days' style='border-bottom:1px solid #2255bb'><span class='extended_day extended_day_1'>Thu</span><span class='extended_day extended_day_2'>Fri</span><span class='extended_day extended_day_3'>Sat</span></div><div class='daily'><span class='extended_day extended_day_1' title='PM Showers'>66/45<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_2' title='Showers'>59/43<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_3' title='Cloudy'>59/48<small>°F</small><br /><i class='wi wi-fw wi-weather-26'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #2255bb'><a href='https://www.weather-us.com/en/washington-usa/kent' title='Weather Atlas - Weather forecast Kent, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Kent, Washington &#9656;</span></a></div></div></div> <div id="text-19" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://www.ilovekent.net/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img class="aligncenter size-full wp-image-147112" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20150'%3E%3C/svg%3E" alt="" width="300" height="150" data-lazy-src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" /><noscript><img class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></noscript></a></p>
</div>
</div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76178" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-17" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76179" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-16" class="et_pb_widget widget_text"><h4 class="widgettitle">Subscribe to our Newsletter</h4> <div class="textwidget"><p>
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fb8b0aece" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE 6pm Daily Digest Newsletter!</label><br />
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><br />
</p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fb8b0aece" tabindex="-1" value=""></div>
<div class="black"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div>
<p></p>
</div>
</div> <div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76166" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--round zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.facebook.com/ilovekent/" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 18px; padding:8px"></span>
 <span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/ilovekentwa" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.instagram.com/ilovekentwa/" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#e4405f" style="background-color : #e4405f; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCPJBGxrGH_jWDXwprWUJHOQ" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
</ul>
</div> <div id="text-13" class="et_pb_widget widget_text"><h4 class="widgettitle">Story Idea or News Tip?</h4> <div class="textwidget"><p><center><strong>Send story ideas &amp; tips to us at:</strong></p>
<p><strong>editor(at)ilovekent.net</strong></p>
<p>You can also text us or leave a voicemail 24/7:</p>
<p><strong>(206) 659-1282</strong></p>
<p>Or call our office at <strong>(206) 248-2565</strong>!</center></p>
</div>
</div> <div id="text-14" class="et_pb_widget widget_text"><h4 class="widgettitle">Traffic Cams</h4> <div class="textwidget"><p><img class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20249'%3E%3C/svg%3E" width="335" height="249" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc01964.jpg?636501523088772706" /><noscript><img class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc01964.jpg?636501523088772706" width="335" height="249" /></noscript></p>
<p><img class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20249'%3E%3C/svg%3E" width="335" height="249" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc02189.jpg?636501523589242393" /><noscript><img class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc02189.jpg?636501523589242393" width="335" height="249" /></noscript></p>
<p><img class="aligncenter size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20244'%3E%3C/svg%3E" width="335" height="244" data-lazy-src="https://images.wsdot.wa.gov/nw/167vc02459.jpg?636753046944636747" /><noscript><img class="aligncenter size-large" src="https://images.wsdot.wa.gov/nw/167vc02459.jpg?636753046944636747" width="335" height="244" /></noscript></p>
</div>
</div> 
<div id="recent-posts-3" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://www.ilovekent.net/2021/05/05/reminder-kent-chamber-luncheon/" aria-current="page">REMINDER: Kent Chamber Luncheon will feature Puget Sound Energy Thursday</a>
</li>
<li>
<a href="https://www.ilovekent.net/2021/05/05/you-can-now-bid/">You can now bid to fly into space on Blue Origin&#8217;s New Shepard</a>
</li>
<li>
<a href="https://www.ilovekent.net/2021/05/05/kent-mayor-discusses-covid-19-relief-with-sen-murray-at-council-meeting/">Kent Mayor discusses COVID-19 relief with Sen. Murray at Council meeting</a>
</li>
<li>
<a href="https://www.ilovekent.net/2021/05/04/kent-councilmember-bill-boyce-appointed-to-harborview-board-of-trustees/">Kent Councilmember Bill Boyce appointed to Harborview Board of Trustees</a>
</li>
<li>
<a href="https://www.ilovekent.net/2021/05/04/king-county-will-stay-in-current-covid-phase-3-for-at-least-next-two-weeks/">King County will stay in current COVID Phase 3 for at least next two weeks</a>
</li>
</ul>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4>
<ul class="wpp-list">
<li>
<a href="https://www.ilovekent.net/2020/03/13/patient-at-kent-quarantine-facility-walks-out-shoplifts-then-escapes-on-bus-fri-morning/" class="wpp-post-title" target="_self">UPDATE: Shoplifting suspect from Kent quarantine facility tests negative for COVID-19</a>
<span class="wpp-meta post-stats"><span class="wpp-views">17.9k views</span></span>
</li>
<li>
<a href="https://www.ilovekent.net/2020/07/01/kent-mans-body-identified-as-one-of-two-found-in-suitcase-off-alki-beach/" class="wpp-post-title" target="_self">Kent man&#8217;s body identified as one of two found in suitcase off Alki Beach</a>
<span class="wpp-meta post-stats"><span class="wpp-views">16.3k views</span></span>
</li>
<li>
<a href="https://www.ilovekent.net/2020/04/03/public-health-seattle-king-county-releases-update-on-non-medical-masks/" class="wpp-post-title" target="_self">Public Health – Seattle &#038; King County releases update on non-medical masks</a>
<span class="wpp-meta post-stats"><span class="wpp-views">14k views</span></span>
</li>
<li>
<a href="https://www.ilovekent.net/2020/03/02/144262/" class="wpp-post-title" target="_self">Man being treated for coronavirus at Burien&#8217;s Highline Medical Center</a>
<span class="wpp-meta post-stats"><span class="wpp-views">9.6k views</span></span>
</li>
<li>
<a href="https://www.ilovekent.net/2020/03/16/update-more-details-released-on-closings-state-local-response-to-coronavirus-outbreak/" class="wpp-post-title" target="_self">UPDATE: More details released on closings, state &#038; local response to coronavirus outbreak</a>
<span class="wpp-meta post-stats"><span class="wpp-views">9.4k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Christopher Roddie</span> on <a href="https://www.ilovekent.net/2021/03/10/hazard-pay-raise-for-grocery-workers-in-unincorporated-areas-approved-by-king-county-council/#comment-10169">Hazard pay raise for grocery workers in unincorporated areas approved by King County Council</a></li><li class="recentcomments"><span class="comment-author-link">Chris</span> on <a href="https://www.ilovekent.net/2021/03/11/kent-lions-club-cancels-farmers-market-for-2021-season/#comment-9778">Kent Lions Club cancels Farmers Market for 2021 season</a></li><li class="recentcomments"><span class="comment-author-link">Scott Schaefer</span> on <a href="https://www.ilovekent.net/2021/03/05/free-spring-themed-face-masks-will-be-given-out-on-sunday-mar-21/#comment-9777">FREE Spring-themed Face Masks will be given out on Sunday, Mar. 21</a></li><li class="recentcomments"><span class="comment-author-link">Julie E. Webb</span> on <a href="https://www.ilovekent.net/2021/03/05/free-spring-themed-face-masks-will-be-given-out-on-sunday-mar-21/#comment-9771">FREE Spring-themed Face Masks will be given out on Sunday, Mar. 21</a></li><li class="recentcomments"><span class="comment-author-link"><a href="http://Www.premiumbead.com" rel="external nofollow ugc" class="url">John johnSon</a></span> on <a href="https://www.ilovekent.net/2021/02/26/bonita-webb-named-kent-school-district-teacher-of-the-year/#comment-9604">Bonita Webb named Kent School District Teacher of the Year</a></li></ul></div> <div id="bs_zones-13" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76172" keywords="not_home_page,not_landing_page,is_article_page,biz-finance,community,featured,kent-news,kent-wa-news,news,nonprofit,reminder-kent-chamber-luncheon,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul id="footer-menu" class="bottom-nav"><li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55"><a href="http://ilovekent.net/new/disclaimer">Disclaimer</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56"><a href="#">Privacy</a></li>
<li id="menu-item-57" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57"><a href="https://www.ilovekent.net/new/advertising/">Advertisement</a></li>
<li id="menu-item-58" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58"><a href="https://www.ilovekent.net/new/contact/">Contact Us</a></li>
</ul> <ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://www.facebook.com/ilovekent/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/ilovekentwa" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon rss">
<a href="https://www.ilovekent.net/feed" class="et-extra-icon et-extra-icon-background-none et-extra-icon-rss"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','biz-finance','community','featured','kent-news','kent-wa-news','news','nonprofit','reminder-kent-chamber-luncheon','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["biz-finance","community","featured","kent-news","kent-wa-news","news","nonprofit","reminder-kent-chamber-luncheon","post"],"url":"reminder-kent-chamber-luncheon"};</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-3bJO3xT2bLtzc.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<script type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.ilovekent.net/wp-includes/js/dist/i18n.min.js?ver=db9a9a37da262883343e941c3731bc67' id='wp-i18n-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-delay-js-js-after'>
(function() {
"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart","wheel"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run();
}());
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.ilovekent.net","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/www.ilovekent.net\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"0e14284961","timeline_nonce":"392be2c69c","blog_feed_nonce":"e6c9da066e","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.ilovekent.net\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/www.ilovekent.net\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"c862096730","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"0969afe3bf","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"147973","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.ilovekent.net/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script src="https://www.ilovekent.net/wp-content/cache/min/1/a09a46123129a39ccd5d1c7886854428.js" data-minify="1" defer></script></body>
</html>
